こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

-広告-

回答受付中の質問

build.gradleのappcompat-v7

◆build.gradleで、appcompat-v7のバージョンエラー
お世話になっております。android開発初心者です。

appレベルのbuild.gradleで、赤線のエラーで困っております。

implementしているところで、appcompat-v7のバージョンエラーで、赤色のアンダーラインのエラーが出ております。バージョンは、何を入れても、エラーになってしまいます。(とりあえず27.1.1と致します)

これは、本当にバージョンのエラーであるのか、それとも、他に問題があって、appcompat-v7のところでエラーを出しているのか、また、これはスルー出来ないものなのか、解らずにおります。

androidstudioのバージョンは、3.1.3です。

support repositoryも最新にしております。

写真のように、appcompat-v7の部分のエラーなのですが、ビルドも通りますし、syncも出来ます。広告もちゃんと表示されますし、ちゃんと動くので、「このままリリースOKかな?」と一瞬、考えました。

しかし、ちゃんとしたものをリリースしなければならないので、解決方法をご教授願いたい次第です。

試しに、同じandroidstudioで、新しいプロジェクトを作成致しました時に、その新しいプロジェクトのbuild.gradleでは、同じappcompat-v7は全くエラーにはなっておりません。

気になるところと致しましては、build.gradleで、admobやグラフなどを使う為に、firebaseやgithubの設定も追加しております。

海外のサイトを調べますと、implementで、これも足しなさい、あれも足しなさい、と、使うか使わないか解らないライブラリがどんどん増えてしまって、それでも解決せず、問題がどこにあるのか、途方に暮れてしまいます。

もし、この問題につきまして、少しでも見当がつく方がおられましたら、どんなアドバイスでも宜しくお願い申し上げます。

投稿日時 - 2018-06-13 13:50:21

QNo.9507937

困ってます

回答(0)

この質問にはまだ回答がついていません。
あなたが最初に回答してみませんか?

-広告-
-広告-

あなたにオススメの質問

-広告-
-広告-